[PATCH] Re: Introducing separate strings for quick bar items
Roland Illig
roland.illig at gmx.de
Mon Jul 18 11:15:54 UTC 2005
Egmont Koblinger wrote:
> On Wed, Jul 13, 2005 at 04:17:19AM +0200, Roland Illig wrote:
>
>
>>This would result in a function like this:
>>
>>const char *translate_ui (const char *s)
>
> With a simpler name, of course :-)))
> I'm just wondering whether __() is fair, or should be treated as it belonged
> to glibc private namespace.
[ISO C99] 7.1.3p1: All identifiers that begin with an underscore and
either an uppercase letter or another underscore are always reserved for
any use.
(Similarly for underscore followed by anything.)
So I've chosen gettext_ui() as the name, because I couldn't find any
better one. Please tell me how you would call it.
> So you only chop the first *| if the string wasn't translated. I think it's
> better to always chop it since then translators can use Ctrl+Space in KBabel
> or any other hotkeys to quickly tell that the translation happens to be the
> same as the original text (which is quite often in en_GB, but also happens
> for other languages). But if the real string doesn't contain a '|', which is
> very likely, then omitting the prefix in the translation would also work.
I've done that.
Roland
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mc-translation-context.patch
URL: <http://lists.midnight-commander.org/pipermail/mc-devel/attachments/20050718/f46a9341/attachment.ksh>
More information about the mc-devel
mailing list